WhatPulse Forums » Support » Client software v » Whatpulse keeps crashing on pulse Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Whatpulse keeps crashing on pulse
11-11-2017, 09:52 PM
Post: #1
Whatpulse keeps crashing on pulse
Might be unrelated, but ever since I have changed my autopulse from 1 hour uptime to 50k keys, Whatpulse crashes on autopulse much more often, sometimes multiple times per day, other times a few times a week, with the pulse succeeding.
I have tried to reset the database multiple times, delete the appdata folder, uninstall and reinstall but to no avail. Therefore database size/age are seemingly unrelated.

I'm using Whatpulse 2.8.1, but I have tried downgrading to an older version and the problem persists, so I'm assuming that the issue is on my end, but I would like to know how to fix it if possible.

app.log: https://www.dropbox.com/s/inqancbvf9rejkd/app.log?dl=0
app.log.old: https://www.dropbox.com/s/kqdahs3i5e21us...d.log?dl=0
whatpulse.db: https://www.dropbox.com/s/kechw3fhbiak7l...se.db?dl=0

Windows 10 x64 and running Whatpulse as administrator.
Find all posts by this user
Quote this message in a reply
11-19-2017, 12:19 PM (This post was last modified: 11-19-2017 12:19 PM by Robby250.)
Post: #2
RE: Whatpulse keeps crashing on pulse
I've noticed a few things:
- When running WhatPulse as administrator, this error pops up consistently in the log every 5 seconds:
Code:
DEBUG GetModuleFileNameEx failed for processId:  4412 0
though the processId 4412 changes to something else sometimes. If I don't run WhatPulse as administrator, this error doesn't show up anymore, but my stats don't record properly in certain programs.

- The whatpulse.db.backup file doesn't seem to create/update itself anymore, regardless of how many times I try to reinstall the program. I tried making it manually by copying the whatpulse.db file, but WhatPulse doesn't work with it, it doesn't get modified at all.
Find all posts by this user
Quote this message in a reply
11-19-2017, 05:11 PM
Post: #3
RE: Whatpulse keeps crashing on pulse
If you look at the process that holds that ID - what is it?

And does the log file mention creating backups? As it is highly unusual that it wouldn't create the backup, have you modified the permissions on the file, or data directory? What happens if you remove the backup file; does it regenerate?

No AV that's giving you a hard time?

There are not really any reports anymore of the client crashing, so I'm looking for something computer specific.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-20-2017, 06:53 AM (This post was last modified: 11-20-2017 09:01 AM by Robby250.)
Post: #4
RE: Whatpulse keeps crashing on pulse
All of these things also happen on both of my laptops, but WhatPulse crashes more rarely on them, maybe because I use them less so they pulse less.

I have looked at the Process IDs, there were no processes under the IDs from the log.

The log doesn't seem to mention anything about backups. The program doesn't even make a backup after a fresh install, and all the backups my laptops have are months old, probably from before I updated WhatPulse on them. And if I remove the backups, they don't regenerate.

I don't have an antivirus (other than Windows Defender, which didn't do anything). The only change I have tried to the appdata folder was unchecking "Read-only". I have looked at permissions and everything seems fine.
Find all posts by this user
Quote this message in a reply
01-13-2018, 10:26 AM (This post was last modified: 01-13-2018 10:31 AM by Robby250.)
Post: #5
RE: Whatpulse keeps crashing on pulse
I went on holiday to a different country for 2 weeks and during that whole time WhatPulse didn't crash a single time on pulse. Then I returned and it crashed on 2 pulses in a row. Could it be related to the network the computer is connected to?

The program still did the previous issues while I was on holiday (no db backup and "GetModuleFileNameEx failed for processId") but those seem unrelated as there were no crashes at all. Also autopulse options/manual pulse don't affect it either. I pulse manually now because it happens too often.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Windows 10 Pulse Notification 00Eraser00 0 81 01-10-2018 01:08 PM
Last Post: 00Eraser00
  [SOLVED] WhatPulse does not allow me to pulse and does not pulse after 50k keys LSC99bolt 2 809 09-30-2017 08:13 PM
Last Post: LSC99bolt
Music Unable to pulse, wrong password? Renewed 0 757 04-22-2017 01:36 PM
Last Post: Renewed
  [SOLVED] Can not Pulse anymore [GoT]Cloudsx 9 2,278 04-03-2017 05:46 AM
Last Post: [GoT]Cloudsx
  [SOLVED] [postmortem] Pulse error: "The specified configuration cannot be used." dgw 4 2,579 03-03-2017 09:54 PM
Last Post: dgw
Bug [CLOSED] What pulse stuck , is what pulse not support for windows 10 ? karahan29 1 1,296 11-05-2016 10:34 PM
Last Post: smitmartijn
  crashing my computer MarioFan835 2 1,214 04-14-2016 11:17 PM
Last Post: MarioFan835
  Mac silently crashing, redux dgw 11 3,550 02-05-2016 10:31 PM
Last Post: dgw
  WhatPulse keeps asking permission to access Keychain moray95 1 1,913 09-15-2015 11:52 AM
Last Post: Megachip
  Forgot to pulse before I installed win10 z2sam 2 2,068 08-29-2015 07:43 PM
Last Post: z2sam

Forum Jump:


User(s) browsing this thread: 1 Guest(s)