WhatPulse Forums
Cannot start WhatPulse using Ubuntu 19.10 - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: Cannot start WhatPulse using Ubuntu 19.10 (/showthread.php?tid=7835)



Cannot start WhatPulse using Ubuntu 19.10 - Adrriii - 10-30-2019 08:53 PM

Hello, just installed a fresh Ubuntu 19.10 with the Qt dependencies and libpcap-dev

Downloaded the x64 Ubuntu release and tried starting ./whatpulse after running the script.

Getting these logs :

30-10-2019 21:50:55.813 INFO "Starting WhatPulse 2.8.4-1633..."
QObject::startTimer: Timers cannot have negative intervals
30-10-2019 21:50:55.892 DEBUG Database file: "/home/adri/.local/share/WhatPulse/whatpulse.db"
Application crashed with signal 11!
Aborted (core dumped)

Tried with/without Wayland, tried the debian x64 dist, tried running as root (crashed because no system tray). Also tried some internet solution by modifying variables when running, did not work.


RE: Cannot start WhatPulse using Ubuntu 19.10 - Adrriii - 11-01-2019 02:37 PM

Seeing other threads, it might be time to actually make a new open source whatpulse on our own, since theres no apparent support anymore...


RE: Cannot start WhatPulse using Ubuntu 19.10 - Juje - 12-16-2019 05:53 PM

(11-01-2019 02:37 PM)Adrriii Wrote:  Seeing other threads, it might be time to actually make a new open source whatpulse on our own, since theres no apparent support anymore...

The devs will never opensource WhatPulse because they are afraid that the ranks will get cheated on (which I understand tbh). But I don't need ranks so I really don't care about that part so ya...
But the team is undermanned at the moment and I hope they will resolve it soon. Until then I'm thinking about cancelling my premium cause I can't even use WhatPulse Sad.


RE: Cannot start WhatPulse using Ubuntu 19.10 - Adrriii - 01-10-2020 01:22 AM

Canceled it a long time ago ...

Edit: Yeah they just removed linux distributions from Downloads, why answer to and fix problems when you can just bury them. I guess we linux users aren't worth it anymore ?


RE: Cannot start WhatPulse using Ubuntu 19.10 - smitmartijn - 01-12-2020 03:52 PM

The download for the Linux client has been removed for now. Due to several changes in several distros, the client is unable to run on ~80% of the systems of people who try it. A few volunteers have stepped up to see about getting it running universally on every/most distros, but that will take a while. In the mean time, there's not much we can do.


RE: Cannot start WhatPulse using Ubuntu 19.10 - roemer2201 - 03-18-2020 03:58 PM

Are there any news regarding this topic?


RE: Cannot start WhatPulse using Ubuntu 19.10 - smitmartijn - 03-21-2020 01:45 PM

No, they are still working on getting it to work.


RE: Cannot start WhatPulse using Ubuntu 19.10 - Lieutenant_Dan - 03-31-2020 09:39 PM

Either way, happy to hear the linux client is getting some much needed attention. Thank you for the update!


RE: Cannot start WhatPulse using Ubuntu 19.10 - Juje - 11-05-2020 02:23 PM

Thanks WhatPulse team for releasing a version for Linux Big Grin.

https://medium.com/whatpulse/an-update-on-the-linux-client-a23d8529964