WhatPulse Forums » Support » Client software v » 2.4 (Lubuntu) network stats problem Welcome back, Guest.


Thread Closed 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.4 (Lubuntu) network stats problem
06-03-2014, 12:43 PM
Post: #1
2.4 (Lubuntu) network stats problem
I have a problem getting the network stats in WP.

Strange enough it does work when i close WP and start it again with a SUDO; then up and download are counted perfectly. If i set the 'start on boot' option while in sudo mode; it doesn't work, just like it didn't work before.

I'm currently running wp from /usr/bin, in the past it ran from /home/%user%/.local/share/applications with the same problem.

also; when i look at the network tab; there it sees and counts traffic while i'm not in sudo mode; but again this traffic is not added to the pulse totals.

So it's clear it CAN count, but currently it will only do so in SUDO mode; what can i do?

I guess it has something to with userrights, but since i'm quite new on linux/ubuntu i don't know how to fix this on my own.
Find all posts by this user
06-03-2014, 07:44 PM (This post was last modified: 06-03-2014 07:45 PM by bogy.)
Post: #2
RE: 2.4 (Lubuntu) network stats problem
i found this info:
Quote:The next is only required on clients earlier than 2.1 - later versions will automatically correct this:
After libpcap installation, you need to tell the OS to allow the WhatPulse binary to hook into the network traffic. To do so, execute this command inside the directory where the binary resides:

sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse


but appearantly it also is needed for 2.4 as this solved my issue immediately
Find all posts by this user
06-07-2014, 11:44 AM
Post: #3
RE: 2.4 (Lubuntu) network stats problem
Only on not-tested distros. Currently, only Ubuntu and Debian are a tested distribution.
Visit this user's website Find all posts by this user
06-18-2014, 03:26 AM
Post: #4
RE: 2.4 (Lubuntu) network stats problem
(06-07-2014 11:44 AM)smitmartijn Wrote:  Only on not-tested distros. Currently, only Ubuntu and Debian are a tested distribution.


Running Ubuntu 13.04 and have recently been having the same issue as OP until I found this thread. Ran the command given by bogy and now it works perfectly. I ignored it before as it says it wasn't needed for the v2.4 client.
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Problem on starting whatpulse Steven793 1 506 03-29-2021 08:17 AM
Last Post: Resowy
  Working with Key Combinations Stats wolverinepeltz 2 475 02-17-2021 09:35 PM
Last Post: wolverinepeltz
  Network stats displayed / counted wrong MrElliwood 0 397 01-30-2021 10:10 PM
Last Post: MrElliwood
  Error: "Network access is disabled." Jourei 5 952 01-20-2021 07:01 AM
Last Post: penguin2233
Question 3.0 not tracking network stats on macOS numbermaniac 0 447 01-02-2021 11:36 AM
Last Post: numbermaniac
  3.0 Mac Network Not Tracking mewturn 3 702 12-30-2020 05:57 AM
Last Post: mewturn
  Weekly Email Stats dpDesignz 1 978 09-09-2020 07:50 AM
Last Post: _V_
  Portable Mode Network Recording ItsRiftzy 1 1,060 09-04-2020 03:25 PM
Last Post: smitmartijn
  Wired Network Stats for USB-C to RJ45 abpop 3 1,515 08-05-2020 01:51 PM
Last Post: abpop
  Uptime problem on Desktop. JetSet 3 2,165 03-15-2020 01:19 PM
Last Post: JetSet

Forum Jump:


User(s) browsing this thread: 1 Guest(s)