• ¡Welcome to the WhatPulse Forums!
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Title: Cannot start WhatPulse using Ubuntu 19.10
Threaded Mode
#1
Hello, just installed a fresh Ubuntu 19.10 with the Qt dependencies and libpcap-dev

Downloaded the x64 Ubuntu release and tried starting ./whatpulse after running the script.

Getting these logs :

30-10-2019 21:50:55.813 INFO "Starting WhatPulse 2.8.4-1633..."
QObject:ConfusedtartTimer: Timers cannot have negative intervals
30-10-2019 21:50:55.892 DEBUG Database file: "/home/adri/.local/share/WhatPulse/whatpulse.db"
Application crashed with signal 11!
Aborted (core dumped)

Tried with/without Wayland, tried the debian x64 dist, tried running as root (crashed because no system tray). Also tried some internet solution by modifying variables when running, did not work.
 
Reply
#2
Seeing other threads, it might be time to actually make a new open source whatpulse on our own, since theres no apparent support anymore...
 
Reply
#3
(11-01-2019, 02:37 PM)Adrriii Wrote: Seeing other threads, it might be time to actually make a new open source whatpulse on our own, since theres no apparent support anymore...

The devs will never opensource WhatPulse because they are afraid that the ranks will get cheated on (which I understand tbh). But I don't need ranks so I really don't care about that part so ya...
But the team is undermanned at the moment and I hope they will resolve it soon. Until then I'm thinking about cancelling my premium cause I can't even use WhatPulse Sad.
 
Reply
#4
Canceled it a long time ago ...

Edit: Yeah they just removed linux distributions from Downloads, why answer to and fix problems when you can just bury them. I guess we linux users aren't worth it anymore ?
 
Reply
#5
The download for the Linux client has been removed for now. Due to several changes in several distros, the client is unable to run on ~80% of the systems of people who try it. A few volunteers have stepped up to see about getting it running universally on every/most distros, but that will take a while. In the mean time, there's not much we can do.
 
Reply
#6
Are there any news regarding this topic?
 
Reply
#7
No, they are still working on getting it to work.
 
Reply
#8
Either way, happy to hear the linux client is getting some much needed attention. Thank you for the update!
 
Reply
#9
Thanks WhatPulse team for releasing a version for Linux Big Grin.

https://medium.com/whatpulse/an-update-o...23d8529964
 
Reply
  


Possibly Related Threads…
Thread Author Replies Views Last Post
  Whatpulse is not tracking anything on linux Xabec 2 274 11-29-2021, 09:08 AM
Last Post: Xabec
  Whatpulse client backup: Access is denied. Galaxied 1 170 11-28-2021, 10:31 AM
Last Post: smitmartijn
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 355 11-03-2021, 10:29 PM
Last Post: Code-E
  Ubuntu issues with network stats XploD 1 406 10-20-2021, 08:21 AM
Last Post: XploD
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 330 09-29-2021, 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,227 09-10-2021, 11:30 AM
Last Post: kitliasteele
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 13,306 08-23-2021, 09:45 PM
Last Post: Tealdragon204
  Whatpulse doesn't track internet up/down correctly on gigibit internet Deuss 2 628 08-19-2021, 08:32 PM
Last Post: lvh1
  Whatpulse client stops tracking keys Sylverblack 0 455 08-04-2021, 04:31 PM
Last Post: Sylverblack
  WhatPulse error on Linux (Elementary-OS 6) Suxhe 0 639 06-13-2021, 10:56 PM
Last Post: Suxhe

Forum Jump:


Browsing: 1 Guest(s)