WhatPulse Forums » Support » Client software v » “Cannot open shared object file” pops up when installing WhatPulse Welcome back, Guest.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
“Cannot open shared object file” pops up when installing WhatPulse
04-22-2020, 06:08 PM (This post was last modified: 04-22-2020 06:10 PM by Gaurav Mall.)
Post: #1
“Cannot open shared object file” pops up when installing WhatPulse
So, I just installed Ubuntu yesterday, together with my main Windows just so I could use it for development. Because of all the keys, I would be typing I thought why not install Whatpulse to keep track of them? But turns out it is a tedious task. So, basically, I followed this guide: Whatpulse (installation guide Ubuntu 14.04), because there isn't anything that is newer.

NOTE: I do use the generic version from the installs.

So, basically this is what I did (after extracting the .gz file of course):

sudo ./setup-input-permissions.sh
sudo apt-get install libqtcore4
sudo apt-get install libqtscript4-core
sudo apt-get install libqt5sql5
sudo apt-get install libpcap-dev
sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse

And then I tried


But it gave me this error:

./whatpulse: error while loading shared libraries: libQt5Sql.so.5: cannot open shared object file: No such file or directory

What does it mean? After a bit of searching I found that by reinstalling and doing this the problem might be resolved:

sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/libQt5Core.so.5

But it still gives the same error. By the way, I didn't install the libqtwebkit4 library because it isn't listed at the official site.
Find all posts by this user
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 2 181 04-26-2021 05:23 PM
Last Post: Lieutenant_Dan
  whatpulse is writing to database every second minho 0 115 04-19-2021 06:52 AM
Last Post: minho
Question Autostart WhatPulse 3.1 without Confirmation (Win10) blankster 0 177 04-04-2021 04:53 PM
Last Post: blankster
Question Can't install WhatPulse 3.1 correctly (Win10) blankster 0 177 04-04-2021 04:49 PM
Last Post: blankster
  When you switch networks WhatPulse stops tracking bandwidth TheEliteFriendsYT 2 471 04-01-2021 10:05 AM
Last Post: TheEliteFriendsYT
  Problem on starting whatpulse Steven793 1 447 03-29-2021 08:17 AM
Last Post: Resowy
  No "Open Geek Window" option h05hardman 4 587 02-05-2021 11:55 AM
Last Post: h05hardman
Bug WhatPulse 3.0 stops responding when running on start up Mevious 6 1,261 01-17-2021 09:18 PM
Last Post: Mevious
  Whatpulse Client and Windows 10 (20H2) d3FC0N 3 1,146 12-29-2020 12:54 PM
Last Post: d3FC0N
  Cannot start WhatPulse using Ubuntu 19.10 Adrriii 8 4,454 11-05-2020 02:23 PM
Last Post: Juje

Forum Jump:

User(s) browsing this thread: 1 Guest(s)