• ¡Welcome to the WhatPulse Forums!
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Title: webAPI
Threaded Mode
#1
Hi,

We got several problems with our webAPI team_parse.php

1. When you fill in teamnumber 1295 (dutch power cows) the parser stops after mr_fré ... he has an eacute (é) in his name but in the XML file it will give an special character Confused , The parser wouldn't parse after him so its verry strange (we use the normal webAPI from here)

2. When we put the errors on (E^all) we'll get many Notice index and notice offset errors Confused

What's the solution?
Thnx,
mastadizzy
 
Reply
#2
To my knowledge, the servers have trouble with any kind of "unusual" characters, like the é. I know that a temporary fix would be to change the name to something like mr_fre or mr_fre`, though I don't see those as ideal solutions. I get too many places that won't let me use my hyphen already Sad
[Image: XKalSig1.png]
 
Reply
#3
I also have problems with < > ' " `

and most special characters.
 
Reply
#4
In that same dutch team (team GoT, 1295) there are some guys that use an & in their name, this has to be converted to &amp; because all XML parser won't be able to parse the XML: it's not well formed!
 
Reply
#5
Special characters should be encapsulated within CDATA-containers.
Escaping characters with an HTML entity inside XML has no sense.
 
Reply
#6
frickY Wrote:Special characters should be encapsulated within CDATA-containers.
Escaping characters with an HTML entity inside XML has no sense.

The use of &amp; &gt; and &lt; are valid within XML (all other "HTML entities" are not) so when you only have one of these characters it is better to use these entities than encapsulating them in a CDATA. Ofcourse when you use CDATA the problem of the high characters could also fixed, but even there it is better to use the right charset.
 
Reply
  


Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Error in team WebAPI Electrosa 4 6,742 09-30-2013, 08:21 PM
Last Post: Electrosa
  Single Computer in WebApi tommytl 2 5,459 02-01-2013, 09:13 AM
Last Post: tommytl
  Difference in number format webapi xml [#WP]KompjoeFriek 3 6,807 09-25-2010, 12:26 AM
Last Post: KompjoeFriek

Forum Jump:


Browsing: 1 Guest(s)