• ¬°Welcome to the WhatPulse Forums!
Hello There, Guest! Login Register

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Title: SSL Handshake Error
Threaded Mode
(Description first, versions below)

I've started receiving the following error dialogue when attempting to report a pulse back:

> Error while talking to website: SSL handshake failed. We recommend trying again in a little while.

My browser and curl don't seem to have problems with the SSL cert on whatpulse.org. However, running whatpulse under dtruss, I saw the following output on attempt to open browser for login:

08-02-2020 10:17:30.497 DEBUG SSL Errors:
08-02-2020 10:17:30.498 DEBUG "The issuer certificate of a locally looked up certificate could not be found"
08-02-2020 10:17:30.498 DEBUG "The root CA certificate is not trusted for this purpose"
08-02-2020 10:17:30.498 DEBUG "No certificates could be verified"
08-02-2020 10:17:30.498 WARN void ClientCommunication::checkHTTPError(QString) Error: "Error while talking to website: SSL handshake failed. We recommend trying again in a little while."

WP version: 2.8.4
OS: $ uname -a
Darwin [hostname] 18.7.0 Darwin Kernel Version 18.7.0: Sun Dec 1 18:59:03 PST 2019; root:xnu-4903.278.19~1/RELEASE_X86_64 x86_64
Me too, on both my Desktop and Notebook.
Same here
Windows 10
Client: 2.8.4
Had a same issue, restarting a application seems to solve the problem.

A system restart allowed a pulse after this error but the error returned when testing using a manual pulse. Curious issue, to the aps credit it has been a long time since I have encountered any issues.
In my Mac and in some Windows machine I still receiving the message. I've also seen some 503 error in this website. Hope the issue will be fixed soon
Same problem here on my Mac, even after restarting the app a few times. Please fix Smile

I've just noticed that after restarting I cannot even log in using my client - same error
Hey folks. We're looking into the problem, I'm having it myself!
Please give it some time. The caching time seems different per computer; but it will be cleared eventually and you'll be able to pulse. All stats are simply kept a little longer on the client in the meantime.
Now is working fine for my Mac. Just to give you a feedback. Thanks for the job!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pulse: Error while talking to website Sylverblack 2 786 10-02-2021, 05:20 PM
Last Post: ssnake42069
  WhatPulse error on Linux (Elementary-OS 6) Suxhe 0 865 06-13-2021, 10:56 PM
Last Post: Suxhe
  Getting a lot of application error cavveman 0 1,278 01-23-2021, 09:01 AM
Last Post: cavveman
  Error regarding missing DLL TheIceMage 7 3,557 01-20-2021, 11:22 AM
Last Post: smitmartijn
  Error: "Network access is disabled." Jourei 5 2,782 01-20-2021, 07:01 AM
Last Post: penguin2233
  OS X Big Sur SSL error firegate666 3 2,457 11-30-2020, 10:03 AM
Last Post: smitmartijn
Question [Win7x64 WP2.5] Error while pulsing: "Wrong Password! Try again." Diamundo 9 9,829 01-18-2020, 12:08 PM
Last Post: Megachip
  Server error: Missing input! with whatpulse 2.8.4 on Win10 Franck.Dernoncourt 3 4,423 09-24-2019, 10:56 PM
Last Post: kolah
Bug server error sggxp 0 2,044 04-25-2019, 04:50 AM
Last Post: sggxp
  [SOLVED] Error uploading keyboard/mouse heatmap Wopian 2 4,382 03-17-2017, 12:26 PM
Last Post: Wopian

Forum Jump:

Browsing: 1 Guest(s)