WhatPulse Forums » Support » Client software v » “Cannot open shared object file” pops up when installing WhatPulse Welcome back, Guest.


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
“Cannot open shared object file” pops up when installing WhatPulse
04-22-2020, 06:08 PM, (This post was last modified: 04-22-2020, 06:10 PM by Gaurav Mall.)
#1
“Cannot open shared object file” pops up when installing WhatPulse
So, I just installed Ubuntu yesterday, together with my main Windows just so I could use it for development. Because of all the keys, I would be typing I thought why not install Whatpulse to keep track of them? But turns out it is a tedious task. So, basically, I followed this guide: Whatpulse (installation guide Ubuntu 14.04), because there isn't anything that is newer.

NOTE: I do use the generic version from the installs.

So, basically this is what I did (after extracting the .gz file of course):

sudo ./setup-input-permissions.sh
sudo apt-get install libqtcore4
sudo apt-get install libqtscript4-core
sudo apt-get install libqt5sql5
sudo apt-get install libpcap-dev
sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse

And then I tried

./whatpulse

But it gave me this error:

./whatpulse: error while loading shared libraries: libQt5Sql.so.5: cannot open shared object file: No such file or directory

What does it mean? After a bit of searching I found that by reinstalling and doing this the problem might be resolved:

sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/libQt5Core.so.5

But it still gives the same error. By the way, I didn't install the libqtwebkit4 library because it isn't listed at the official site.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Whatpulse is not tracking anything on linux Xabec 2 227 11-29-2021, 09:08 AM
Last Post: Xabec
  Whatpulse client backup: Access is denied. Galaxied 1 135 11-28-2021, 10:31 AM
Last Post: smitmartijn
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 307 11-03-2021, 10:29 PM
Last Post: Code-E
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 299 09-29-2021, 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,187 09-10-2021, 11:30 AM
Last Post: kitliasteele
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 13,188 08-23-2021, 09:45 PM
Last Post: Tealdragon204
  Whatpulse doesn't track internet up/down correctly on gigibit internet Deuss 2 591 08-19-2021, 08:32 PM
Last Post: lvh1
  Whatpulse client stops tracking keys Sylverblack 0 425 08-04-2021, 04:31 PM
Last Post: Sylverblack
  WhatPulse error on Linux (Elementary-OS 6) Suxhe 0 610 06-13-2021, 10:56 PM
Last Post: Suxhe
  whatpulse is writing to database every second minho 1 845 06-11-2021, 07:00 PM
Last Post: Alexey..Zubenko

Forum Jump:


Users browsing this thread: 1 Guest(s)